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Login to PC
use procedure pinned to the screen (EUMETSAT training PCs only)

kill Office Communicator (EUMETSAT training PCs only)

copy McVTutorial folder from flash memory to Desktop

Download site for McIDAS-V
McIDAS-V site: http://www.ssec.wisc.edu/mcidas/software/v/

most recent stable version for Windows XP/Vista/7

32-bit: McIDAS-V_1.2_windows_installer.exe

64-bit: McIDAS-V_1.2_windows64_installer.exe

PCs in this room: 2 gigabytes RAM, Windows XP (32-bit)  maximum RAM available for →
McIDAS-V:1 megabytes

(much improved performance with RAM>3.43 gigabytes and 64-bit OS)

Installation of version 1.3beta1
open Installer folder in McVTutorial folder

double-click McIDAS-V_1.3beta1_windows(64)_installer.exe (1.3beta1 is from 14 
November 2012!)

start installation (including disinstallation of older version, if there):

[authorise installation]

Next

check I accept agreement – Next

Next

[Browse – OK choice (e.g. Desktop)* –] Next 

Next

Next

wait

[authorise disinstallation of previous version]

wait

Next

Finish

start McIDAS-V using shortcut on Desktop

McIDAS-V creates a folder McIDAS-V in the home directory of the user – all 
changes/addons done by the user end up there, including a log file mcidasv.log.

The system modules and folders are saved in a folder called McIDAS-V-System in the 
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(default) path chosen during the installation*.

If McIDAS-V runs into severe problems or is blocking the PC, remove/rename folder 
McIDAS-V, restart and inspect file mcidasv.log.

Installation of de-compressing MSG HRIT reader
HRIT-coded data from the archive or EUMETCast/GEONETCast are wavelet-compressed. 
The HRIT reader iin the installation file is not de-compressing (i.e. de-compression would 
have to be done externally). The HRIT reader with integrated de-compression still is in 
prototype phase, but works fine (only available for Windows Oss).

open DecompressingMSG-HRIT folder in McVTutorial folder

copy msgtaget.exe to folder …/McIDAS-V-System/adde/bin

(depending on where the folder McIDAS-V-System is installed, administrative rights will be 
reuqested in order to overwrite the existing version of msgtaget.exe, caution: overwriting 
will have to be done after each update or new installation of McIDAS-V)

Starting McIDAS-V
start McIDAS-V using shortcut on Desktop

McIDAS-V creates a folder McIDAS-V in the home directory of the user account – all 
changes/add-ons done by the user end up in this folder, including a log file mcidasv.log.

Documentation
Help > User's Guide

more documents and tutorials at http://www.ssec.wisc.edu/mcidas/software/v/ 

post support requests from inside McIDAS-V

consult McIDAS-V Support Fora

McIDAS-V windows
By default McIDAS-V creates two windows at startup:
- Data Explorer handles the data requests and loading.
- a display window, called McIDAS-V by default, displaying processed data.

Additional display windows with single/multiple panels of different types may be created 
(File > New Display Window > [select] > [select]). More tabs of different types may be 
added to each display window (File > New Display Tab > [select] > [select]).

In the bottom left-hand corner of the display windows RAM usage is shown. Right-
clicking toggles between RAM usage and wall clock. 
RAM usage is 3 numbers:
right-hand number: reserved RAM as per Preferences
middle number: maximum RAM usage in current session
left-hand numbers: current RAM usage

McIDAS-V Tutorial revised, ESCA-X-F Niamey, November 2012 3



Middle number is only increasing. Left-hand number is changing continuously changing, 
increasing due to processing needs and decreasing due garbage collection (freeing RAM). 
Background of RAM information turns from white to pink when RAM usage is becoming 
critical. When going from pink to red problems might loom, i.e. system will slow down 
and, in the extreme, my get blocked.

Installation of plugins
EUMETSAT

Tools > Plugins > Manage

File > Install Plugin From File

browse to Desktop > McVTutorial > Plugins

open EUM-McVplugin_Nov2012.jar

click OK

plugins work only after a restart, but do not restart yet!

Panoply (needs internet access)

explore Available Plugins

click + in front of Color Tables (list of colour tables)

click + in front of Panoply Color Tables

now restart McIDAS-V

Settings
Edit > Preferences

General / General

items may be (un)checked at convenience (typically have nothing checked)

General / Layer Controls

check Use fast rendering (closes data gap along 0° longitude in non-native projections, 
but may create other spurious display anomalies)

General / When Opening a Bundle

from dropdown list select Replace session

Display Window / Panel Configuration

uncheck Show Wireframe Box (wireframe box may be helpful as reference in 3D displays)

uncheck Reset Projection With New Data (very important: does not reset display to native 
projection – awkward and time consuming when fusing data from different sources e.g. 
from different satellite orbits)

Display Window / Color Scheme

click colour box at Background and change colour to a dark grey
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Display Window / Layer List Properties

change Font to Arial with size 14

Display Window / Default Projection

select Mercator from dropdown list

Navigation Controls

check radio button Custom

interchange Translate and Rotate under Right (MB3) (preferred use of right-click is 
moving/panning an image, not rotating/tilting)

Formats & Data / Formats

delete :ss in Date Format

replace GMT by UTC from dropdown list in Time Zone

Formats & Data / Data

in Sampling Mode check radio button Nearest Neighbour  (readout of native pixel values 
also when re-sampled in a non-native projection)

Advanced / Startup Options / Memory

(if use of 80%-option blocks McIDAS-V, try manual mode - increase stepwise starting from 
512 megabytes)

Advanced / Startup Options / Defaults

uncheck Specify default bundle (otherwise might add another tab in McIDAS-V window

Advanced / Startup Options / Misc

check Enable concurrent mark-sweep garbage collector (improves garbage collection over 
standard procedure – better RAM management)

Advanced / Startup Options / VisAD

handling of Enable access to geometry by reference:

option checked – might create spider webs with certain (global) maps

option unchecked – no spider webs, but allowed size of datasets will decrease due to 
inefficient RAM use

we are done with Preferences

click OK

Change default layout of McIDAS-V window
Experience shows that white (also black) map outline match best with coloured 
imagery/charts, in particular with standard RGB composites (default map outline in 
blue/cyan is an inferior choice). Also, it has proven practical to have a Mercator-projected 
world map centred on 0° longitude at start-up.

at the top of the display click Projections > Predefined > Mercator
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click Default Background Maps under Legend widget – Data Explorer window shows up

uncheck North & Central America

click colour box of World Political Boundaries and change colour to white

click colour box of World Coastlines and change colour to white

optionally create geographical grid and label grid:

click Lat/Lon tab above map list

for Latitude change Intervsl to 10, Style to … and Color to white

(Longitude is automatically updated the same way)

click McIDAS-V window and inspect result

look at possibilities to ad/change labels of lat-lon grid and try them

resize McDAS-V window and/or displayed map to match screen dimensions if desired, 
finally make sure that the window content is complete out to the dust bin that is displayed 
at the extreme right in the Legend

click File > Default Layout > Save

click Background Maps in Legend

click File > Default Maps > Save as the Default Map Set in Layer Controls

restart

McIDAS-V window now shows white map outlines in Mercator projection on dark-grey 
background

Change of default map in case of criss-crossing map outlines
With certain video card/driver combinations (e.g. ATI Radeon with old driver) some maps 
produce criss-crossing lines - as a workaround another map may be selected:

double-click Default Background Maps in the Legend of the display

uncheck all maps on the Data Explorer

check World Country Outlines (less accurate than previously selected maps)

click colour box and select white colour

click File > Save Favorite ...

check Save with relative paths (always recommended when hitting this widget)

fill Name with default

click OK

click File > Default Layout > Save
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Site configuration
McIDAS-V can be customised further in variety of ways through XML files and by setting 
paths. For details see Help > User's Guide > Site Configuration.

Installation of remote/local ADDE servers
ADDE (Abstract Data Dissemination Environment) servers are a generic tool for accessing 
local or remote data sets of any kind, typically satellite imagery or point data. We install 
one remote ADDE for accessing near-real-time SEVIRI data and some local ADDEs that 
give access to locally stored imagery from various imagers.

Tools > Manage ADDE Datasets

remote (near-real-time SEVIRI data)

(account is only enabled during the training event – otherwise access to SEVIRI data is 
through the local MSG HRIT ADDE server and HRIT data from the EUMETSAT Data 
Centre, see below)

File > New Remote Dataset

Server: adde.eumetsat.int

Dataset: EUM_AD

check specify accounting information

Username: THP

Project #: 1077

check Image

click Verify and Add Server

wait until widget disappears - installed

local (images from MODIS, MFG, AVHRR Metop, SEVIRI)

1

File > New Local Dataset

Dataset: MODIS

Image Type: MOD/MYD02

Format: MODIS MOD 02 - Level 1B ... (from dropdown list)

Directory: browse to ...McVTutorial/MODIS

click Add Dataset
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2

File > New Local Dataset

Dataset: AVHRR1B

Image Type: METOP

Format: Metop AVHRR L 1b (from dropdown list)

Directory: browse to ...McVTutorial/Metop

click Add Dataset

3

File > New Local Dataset

Dataset: MVIRI

Image Type: OpenMTP

Format: Meteosat OpenMTP (from dropdown list)

Directory: browse to ...McVTutorial/MVIRI

click Add Dataset

4

File > New Local Dataset

Dataset: SEVIRIFD

Image Type: HRIT

Format: MSG HRIT FD (from dropdown list)

Directory: browse to ...McVTutorial/SEVIRIhrit

click Add Dataset

(server for HRV is similar)

we are done

check that Local Servers are running. is greyed, otherwise click OK to the right

cancel widget

Caution: some ADDE servers require that data files not be mixed with other files – it is 
good policy to store have in separate folders

McIDAS-V Tutorial revised, ESCA-X-F Niamey, November 2012 8



Exercise 1: Standard RGB composites using SEVIRI HRIT data

Data selection

go to Data Explorer

select Satellite > Imagery in Data Sources tab

select <LOCAL-DATA> for Server and SEVIRIFD for Dataset

click Connect

select HRIT for Image Type

click Absolute tab

uncheck Create preview image (only useful when working with single-channel imagery)

explore timeline options (e.g. Interval, Sunrise/Sunset)

select all time slots

click Add Source and wait

Data Explorer jumps to Field Selector tab

Dust RGB – DUST

open SEVIRI RGB dropdown list under Fields (click on key symbol)

note listed RGBs

select DUST

in lower part under Displays click Advanced tab

under Image Size click ”expand” icon in front of lock icon  → full resolution – full disc

under Location change Lat to -40 and Lon to -40

change Image Size to 1000 x 1000

inspect selected region by clicking on Region tab (gives also alternative region selection 
with “shift/click” rectangle)

click Create Display at the bottom and wait

in display window go to Projections > Predefined dropdown list and select SAmericaPS

pan-zoom to display by shift/clicking a rectangle around it (other pan/zoom options 
available)

on top of image explore timeline and animation options

click HRIT (All Bands) … in Legend  → Layer Controls tab  → Data Explorer shows up

click “i” icon at the bottom  → Properties window shows up

in Layer Label delete macro %displayname% and insert macro %shortname% by clicking 
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Add Macro > Field Short Name

click Add Macro > Add for this type of display  → make changes permanent in Layer Label

click Apply and inspect Data Explorer

optionally do other changes

click OK

go Edit > Preferences > Display Window > Panel Configuration 

check Show Times in Panel and click Apply at the bottom  observe date-time label in →
lower right-hand corner of display

click Cancel at the bottom  → leave Preferences unchanged

right-click HRIT (All Bands) … in Legend  dropdown list appears→

go from View to Display List to Show Display List and click it → layer label is deleted

repeat action  label re-appears→

Save single frame

click View > Capture > Image

browse to Desktop for saving path and insert filename 1.png

click Save  → image marked in blue on timeline is saved as 1.png on Desktop

Save frame sequence

click View > Capture > Movie

under Image Files check Save Files To

browse to Desktop and insert filename %time:yyyyMMddHHmm%_DUST.png
or other filename by using variation of construct above or simple text

click Time Animation under Capture  movie frames are saved to Desktop→

widget appears for optionally saving movie

choose Animated GIF (*.gif) from dropdown list in Files of Type

browse to Desktop and insert filename 1.gif

save and inspect it

Save work – McIDAS-V zipped data bundle

click File > Save Bundle on Data Explorer

check Save with relative paths (recommended for portability)

browse to Desktop

insert filename ex1 and select file type *.mcvz
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check all check boxes that come up and click OK

(saves display template with the dataset used)

Generic cloud microphysics RGB – GCMP

go back to Data Explorer and Field Selector

click GCMP from SEVIRI RGB dropdown list

make sure that RGB Composite in Displays is highlighted

click Create Display

explore Legend 

compare DUST and GCMP by toggling tick of RGB Composite in Legend

click RGB Composite  → Layer Controls in Data Explorer appears

play with ranges (K) and gammas (1/gamma!):

1. red 4 / 2 (press Enter after each entry!)

2. green 0 / 15 gamma=.4

3. blue 261 / 289

compare DUST and GCMP by toggling between them

modify ranges:

1. red 0 / -

2. green 1000 / 1000

3. blue 1000 / 1000

compare again

modify ranges again:

1. red 1000 / 1000

2. green 0 / 15

3. blue 1000 / 1000

compare again

Measure displacement speed of plume head

activate DUST display only

select Display > Add Range and Bearings

in Legend under General click Range and Bearings

select Edit > Selector Color > black (colour of range bar)

click triangle on range bar and move bar over plume head

shorten bar by click-dragging square symbol close to plus symbol
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zoom in

click-drag plus and square symbols to a prominent pattern in the plume head at 10:30 and 
14:15, respectively

read distance in Legend and calculate speed

Specifying display with explicit image dimensions

click View > Properties on top of display

set Width and Height at bottom of Properties widget to appropriate pixel numbers, e.g. 
520/320

click OK

click View > Full Screen  new display window with defined image dimensions→

note that, depending on graphic card/driver, one cannot return to the original display 
window, however the width/height might be changed to other values – try 600/600

Discussion of implemented SEVIRI RGB composites

RGBs using the solar part of IR3.9 are not implemented. Considering the rather limited 
value of these RGB schemes, implementation of e.g. the Rosenfeld procedure for the 
separation of the solar signal in IR3.9 was not considered worth the effort up to now 
(volunteers are welcome, though!).

RGBs are implemented via procedures written in Jython and stored in the Jython Library:

Tools > Formulas > Jython Library > User Library

[discussion]

Jython code is called via formulas:

Tools > Formulas > Edit formula > SEVIRI RGB > DUST (...

[discussion]

(RGB procedures may be also used for AVHRR and MODIS by choosing SEVIRI proxy 
channels)

direct coding of a formula without using Jython code is possible (for simple one-line 
operations)

Tools > Formulas > Edit formula > SEVIRI Products > MPE (...

[discussion]
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Exercise 2: MODIS Dust RGB composite (DUST)

click File > Open File... in Data Explorer

browse to ex1.mcvz

click Open

click OK in Open bundle widget

click Remove all layers

click Remove all data

click OK in Zip file data widget  DUST imagery of → former exercise is back

in Data Sources tab of Data Explorer set Server to <LOCAL-DATA> and Dataset to MODIS

click Connect

select MOD/MYD02 for Image Type

click Absolute tab and inspect available time slots

click Add Source and wait 

under Data Sources click Formulas

under Fields open SEVIRI RGB

click DUST...

click Create Display

assign MOD/MYD02 (All Bands) > 8.5288 μm Cirrus... > Temperature to IR87 (wait)

assign MOD/MYD02 (All Bands) > 11.0186 μm Surface... > Temperature to IR108 (wait)

assign MOD/MYD02 (All Bands) > 12.0385 μm Surface... > Temperature to IR120 (wait)

in bottom right-hand widget in Advanced tab click “expansion” icon  selects full →
resolution and whole area of dataset

click OK and wait

match MODIS with closest SEVRI slot

toggle between MODIS and SEVIRI image and observe differences/similarities
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Exercise 3: NWP wind fields

go to Data Explorer

select Gridded Data > Local in Data Sources tab

inspect Data Type dropdown list – leave I'm Feeling Lucky

in Look In browse to ECMWF folder and select grib file

click Add Source

click key icon at Derived

click Flow Vectors …

click Wind Barb Plan View in Displays

click Create Displays  crowded wind field→

click ECMWF... in Legend

adjust various parameters:

set Size to 6

click Autoscale

set Skip XY to 4

set Color to black

set Line Width to 2

set Levels to 600

inspect display by moving through time slots

check with wind speed measured earlier on

uncheck wind field

revert to Field Selector

click Speed... in Fields

click key icon at 3D Surface in Displays

click Isosurface

click Create Display

set Isosurface Value to 50 in Layer Controls

tilt display with DUST image by right-click/CTRL/dragging mouse

revert to top view

draw speed contours and explore options
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Exercise 4: AVHRR Natural Colour RGB Composite (NCOL)

click scissor icon to remove all displays and data

click Memory and click Clear... in lower left-hand corner of Display window  further →
clearing of Java heap

set Server to <LOCAL-DATA> and Dataset to AVHRR1B

click Connect

select Metop for Image Type

click Absolute tab and inspect available data

click Add Source and wait

under Data Sources click Formulas

under Fields open SEVIRI RGB

click NCOG

click Create Display  Field Selector window opens→

assign Metop (All Bands) > 0.63 μm VIS... > Reflectivity to VIS06 (wait)

assign Metop (All Bands) > 0.86 μm VIS... > Reflectivity to VIS08 (wait)

assign Metop (All Bands) > 1.61 μm Near... > Reflectivity to NIR16 (wait)

in bottom right-hand widget in Advanced tab click “expansion” icon

click OK and wait

click Projections > Predefined > EuropePS-10W on top of display and zoom in

play with gamma correction (below colour beams) in Layer Controls and try to enhance 
faint veil between Atlantic coast and cloud system to the west
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Exercise 5: SEVIRI products

AMV (BUFR)

click Data Sources > Gridded Data > Local

browse to …/SEVIRIproducts/MSG2-SEVI-MSGAMVE-0100-0100-20110407114500.000000000Z-1002802.bfr

click Add Source

in Fields click Point Data

click EUMETSAT > AMV... in Layout Model tab 

click Create Display

inspect plot with winds scaled to quality and coloured by pressure level

check station model by clicking the double down-arrow at Layout Model and Edit

CLA (BUFR)

CLAP: cloud layers with cloud type and coverage, height and temperature

click Data Sources > Gridded Data > Local

browse to …/SEVIRIproducts/MSG2-SEVI-MSGCLAP-0000-0000-20111030234500.000000000Z-1017702.bfr

click Add Source

in Fields click Point Data

click EUMETSAT > CLA... in Layout Model tab 

click Create Display

inspect plot with coloured cloud amounts at low, medium and high level

check station model by clicking the double down-arrow at Layout Model and Edit

right-click symbols and inspect symbol shapes and colours

vary observation density using density slider or unchecking Declutter

CLA (GRIB)

CLAI: scenes type for each image segment

click Data Sources > Gridded Data > Local

browse to …/SEVIRIproducts/MSG2-SEVI-MSGCLAI-0000-0000-20110407114500.000000000Z-1003164.grb

click Add Source

click Pixel scene... in Fields and Color-Shaded Plan View in Displays

click Create Display

inspect cloud analysis image and compare with cloud layer display above
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GII TPW (BUFR)

click Data Sources > Gridded Data > Local

browse to …/SEVIRIproducts/MSG2-SEVI-MSGGIIN-0101-0101-20110407110000.000000000Z-1002802.bfr

click Add Source

in Fields click Point Data

click EUMETSAT > GII – Total... in Layout Model tab

uncheck Use Default in Region tab

select an area over Europe by left-click/dragging mouse

click Create Display

inspect plot with coloured cloud amounts at low, medium and high level

check station model by clicking the double down-arrow at Layout Model and Edit

right-click symbols and inspect symbol shapes and colours

vary observation density using density slider or unchecking Declutter

open Gridded Fields and click Precipitable_water in Fields

click Color-Shaded Plan View in Displays

click Create Display

(other GII parameters available)

MPE (GRIB)

instantaneous rain rate is given in kg/m2/s (~ mm/s for water)  very small numbers and →
common unit is mm/hr  conversion, i.e. → write a formula

in Display window select Tools > Formulas > Create Formulas

Name: Rain rate

Formula: a*3600

click Add Formula

Data Sources > Gridded Data > Local

browse to ...\SEVIRIproducts\MSG2-SEVI-MSGMPEG-0100-0100-20090830180000.000000000Z-1002820.grb

click Add Source

click Formulas in Field Selector under Data Sources

select Rain rate in Fields

select Color-Shaded Plan View in Displays under Plan Views

click Create Display

in Field Selector widget select MSG2... > 2D_grid > proj1 > Instantaneous_Rain...

click OK and wait
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inspect precipitation fields

left-click colour bar in Legend and click Change Range

click User Predefined > From Color Table

click OK

explore different colour tables and yet another range by clicking MSG2...MPEG... in 
Legend and then changing adequate items in Layer Controls tab

MPE (GRIB)

Rainfall accumulation can be done by summing up a sequence of grib fields. However, this 
affords a rather powerful PC, even for only a couple of time slots. 6 grib files are in sub-
folder RainAccumulation.

Using the same conversion formula as above the resulting amounts are 4 times too big – 
why?
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Exercise 6: Metop products

ASCAT winds

Data Sources > Gridded Data > Local

browse to ...Metop/ascat_20110407_103000_metopa_23168_eps_o_125_1019_ovw.l2.nc

click Add Source

in Fields select 2D grid > Derived (Oceanographic... > Ocean...wind_speed...wind_dir)

in Displays select Wind Barb Plan View

click Create Display

click ascat... under Flow Displays in Legend

in Layer Controls under Wind Barbs put Size to 2 [Enter], click Autosize (additionally thin 
data with Skip box)

zoom in on Cape Verde area

in Fields select 2D grid > Derived (Oceanographic... > Ocean...model_speed...model_dir)

click Create Display

change wind barbs as done before

inspect difference between model winds and ASCAT-derived winds

delete displays

ASCAT surface soil moisture

browse to ...Metop/M02-ASCA-ASCSMR02-NA-2.0-20110727092400.000000000Z-1010028.bfr

in dropdown list of Data Type select netCDF/GEMPAK Point Data files

use station model EUMETSAT > SMR...

select Subsahel region

in Fields click Point Data

click Create Display

press radio button Multiple in Time tab of Layer Controls

zoom in on Ivory Coast

slightly increase data density moving Density slider in Layout tab

with adequate density observe varying dot sizes reflecting data quality

inspect station model (Tools > Station Model Template > Layout Models > EUMETSAT > 
SMR)

right-click magenta dot and using Properties delete Scale by Parameter in Scale Size tab 
click Apply
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inspect changes in display

Polar winds

load all 4 files ...Metop/M02-AVHR-AVHAMV02-NA-1.0-20111108...000000000Z-1019016.bfr in one go

in dropdown list of Data Type select netCDF/GEMPAK Point Data files

in Fields click Point Data and first file (of 4)

use station model EUMETSAT > AMV...

click Create Display

press radio button Multiple in Time tab of Layer Controls

select adequate projection

animate
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Exercise 7: Jason products

SWH (Significant Wave Height)

browse to ...Jason/JA2_OPR_2PdS155_122_20120920_190312_20120920_205116.nc

click Point Data

use station model SWH...

select area from Gulf of Guinea Antarctica as Region

click Create Display

click yes to possible question about number of observations and wait

press radio button Multiple in Time tab of Layer Controls

zoom in and set adequate data density

inspect display

inspect station model and check how data display is suppressed over land
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Exercise 8: Real-time SEVIRI and NCEP model data

Airmass RGB

in Data Sources tab of Data Explorer select Satellite > Imagery

set Server to adde.eumetsat.int from dropdown list

click Connect

set Image Type to M9 - M9 from dropdown list

choose a synoptic time slot and, if possible, an area with much cold cloud

click Add Source

display AIRM (Fields > SEVIRI RGB) in full resolution (Advanced) over West Africa 
(Region)

click Create Display and wait

IR10.8 – semi-transparent cold-temperature overlay

display IR10.8 temperature (and change colour table and range)

go to Layer Controls of IR10.8 display and click button at Color Table

from dropdown list click Satellite > Group 2 > Convection Transp

inspect colour table (range, colouring, transparency) by clicking button again and selecting 
Edit Color Table

inspect display and correct temperature range if scene is warmer than expected by the 
default setting

display colour bar in image by clicking the “i” icon in Layer Controls and Color Scale tab in 
Properties window

click Visible

check colour bar on display and apply changes if desired

when done click OK

NCEP

in Data Sources tab of Data Explorer select General > Catalogs

in Data SourceType select IDV catalog > Unidata IDD... > UCAR (motherlode) > Global 
Forecast… > NCEP GFS Global 2.5 degree > Latest...

match time slot with time slot of imagery above

click Add Source

select 3D grid > Mass > Geopotential_height @ pressure

select 50000Pa in Level tab (500hPa)

select Africa area east of 0° in Region tab (area straddling 0° not possible, sorry)
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click Create Display

go to Layer Controls tab in Data Explorer and modify chart to your liking using the options 
found under keywords Contours, Color Tables, Smoothing and Levels

go to Field Selector and display another model parameter
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Exercise 9: SEVRI channel analysis

Data selection

in Data Sources tab of Data Explorer select Satellite > Imagery

set Server to adde.eumetsat.int from dropdown list

click Connect

set Image Type to M9 - M9 from dropdown list

select 5 most recent in Relative tab

click Add Source

display IR10.8 temperature in full resolution (Advanced) over West Africa (Region) 

with IR convection (Settings) as colour table

click Create Display and wait

Simple data probe

click Projections > From Displays > Image (MSG...  → native projection of SEVIRI data 
(satellite projection)

if map outlines are broken click Default Background Maps in Legend and check Fast 
rendering boxes of checked maps

middle-click and hover over display – watch dynamic readout at the bottom of the window

Time series of data probe

go to Field Selector in Data Explorer

select IR10.8 Temperature and Data Probe/Time Series under General in Displays

click Create Display

go to Data Explorer

select View > Undock from Data Explorer

move coloured square over IR10.8-image and watch changes in time series

use timeline at bottom of time series and watch changes

when finished click dustbin on the right of Data Probe... in Legend

Data transect

go to Field Selector in Data Explorer

select IR10.8 Temperature and Data Transect under General in Displays

click Create Display

select View > Undock from Data Explorer

move transect line over IR10.8 image and watch changes in cross section
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use timeline at top of cross section and watch changes

when finished click dustbin on the right of Data Probe... in Legend

Scatter plot

x-axis of plot:

Field Selector in Data Explorer

select WV6.2 Temperature and Scatter Analysis under Imagery in Displays

click Create Display

y-axis of plot:

click WV7.3Temperature in Field Selector under M9 – M9 (All Bands)

uncheck Use Default and select first time slot in list

click OK and wait  3 plots: image for x-axis – image for y-axis - scatterplot→

select View > Undock from Data Explorer

analysis drawing boxes:

click Box radio button

click magenta-coloured box

use shift/left-click and drag to draw a box over a region of the scatter plot  →
corresponding points in both images are highlighted

select a region of interest in one of the images  corresponding points in scatter plot are →
highlighted

alternatively click Curve radio button and draw enclosed shape on either scatterplot or 
image  same result as with box→

one box/curve per colour allowed

datasets from different time slots or different data sources may be compared
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Exercise 10: IASI level 1C (EBBT)

load bundle …/Bundle/ex1.mcvz

in Data Sources tab of Data Explorer select Satellite > Hydra

browse to …/Metop/IASI_xxx_1C_M02_20110606104100Z_20110606105507Z_N_O_20110807155039Z.h5

click Add Source

select Imagery > Multispectral Display in Displays

click Create Display

move a probe over displayed data – note temperature indications

move one probe over Cirrus (black area in DUST) and the other one over the ash/SO2 

plume (yellow streak in DUST)

go to Layer Controls in Data Explorer

select View > Undock from Data Explorer

inspect the 2 spectra corresponding to the position of the 2 data probes

move probes across image – observe changing spectra

move green line in spectra (or specify a wavenumber) – observe changing image

select Imagery > Linear Combinations in Displays

click Create Display

from list below patiently copy green commands and paste them line by line at the
>> >mark

hit Enter key after each paste in order to execute command

watch what happens in the spectrum as you continue to execute commands

zoom to the spectrum in order to have a better view of the selected lines

IR7.3 - lo-wn

b71=selector(1407.25,'red')

s71=selector(1371.5,'orange')

combine(b71-s71,'SO2-71')

IR7.3 - hi-wn

b72=selector(1408.75,'magenta')

s72=selector(1371.75,'yellow')

combine(b72-s72,'SO2-72')

IR7.3 - average

combine(.5*(b71+b72-s71-s72),'SO2-7a')

go to Field Selector and click on key icon of U-MARF/EPS.....
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click SO2-71

click Create Display (Image Display is preselected and is the correct display type)

click Image Display in Legend on the right side

Layer Controls tab in Data Explorer window is activated

change colour bar by clicking Gray Scale > Miscellaneous > VisAD

change temperature range by clicking VisAD > Change Range

reset range to 0 and 20

click information icon (i) at the bottom of Data Explorer window

in Properties window change Legend Label and Layer Label to SO2-71

repeat yellow procedure accordingly for remaining images in drop-down list

inspect images

compare SEVIRI with IASI doing scatterplot of IR10.8 vs 926nm
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Exercise 11: Setting screen dimensions (draft)
To save an image as a consistent size, it is easiest to use the Full Screen Mode found in the View menu of the 
main display.

1. Before selecting View Full Screen, set the desired screen dimension
Click View>Properties
Set the Full Screen Dimensions

2. Select View>Full Screen

It is best to construct the graphics in the full screen mode when using the set dimensions for proper 
placement of graphics.

When the bundle is saved, the graphic will be saved with the set dimensions. The bundle can be opened with 
any option except "Merge with Active Tabs" and the 
Full Screen Size will be retained.

There is a bug which occasionally places the graphics incorrectly when the bundle is loaded and the user 
opens the full screen. The following workaround helps:

1.) For colorbars, open Edit>Properties>Color Scale of the layer, click Apply.
2.) For layers added using Display>Draw Freely

When Draw Freely is used, make sure to select the option View>Dock in Data Explorer when first 
creating the graphic

When the bundle is reloaded, double-click on each glyph, click Apply in the resulting window
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Exercise 12: Jython shell

display small image of IR10.8 temperature with IR convection colour table

click Tools > Formulas > Jython Shell

from file text&colourbar-JS in …/JythonShellCommands copy and paste 1st command line 
into box at Evaluate button

edit absolute path

click Evaluate

inspect image 2.png that has been saved in the indicated path

from file text&colourbar-JS in …/JythonShellCommands copy and paste 2nd command line 
into box at Evaluate button

edit absolute path

click Evaluate

inspect image 3.png

more in Help > McIDAS-V Scripting in Support Forums
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Exercise 13: Jython libraries and code (not done yet)
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Exercise 14: Globe Display

File > New Display Tab > Globe Display > One Panel

inspect display

load an image composite from free ADDE server

Server: adde.ucar.edu

Dataset: GINICOMP

Image Type: GMC24KIR – GINI 24 km 10.7 um Multi-Composite

Fields: Temperature

Settings: IR convection

globe viewpoint (vertical icon list to the left – 8th icon) for having Eurafrica upfront
Azimuth from North: 270
Tilt down from top:    90

alternatively click Projections > Viewpoints > 0 (or other items in the list)

turn globe: ctrl/click and swipe mouse across display

globe display is 3D
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Exercise 15: MVIRI imagery from IODC

use local ADDE server MFG to load file OpenMTP_2008-08-09_28_712345_1_1_1.IR from 
folder MVIRI and display IR channel

Notes:

• Data files have to be full-disk and in OpenMTP format

• Data files to be stored above 6th sub-directory level
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Exercise 16: Importing pictures

Pictures in equilateral lat-lon projection (also “plate carree”, in McIDAS-V “World”) with 
known upper left-hand and lower right-hand corner coordinates may be imported into 
McIDAS-V using a simple XML file for navigation (extension: *.ximg)

click General > Files > Directories in Data Sources

browse to .../EquilatPictures/20100530-0605TCHP.ximg and open it

inspect display and 20100530-0605TCHP.ximg file with e.g. Wordpad
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Exercise 17: Annotations

Adding your own location labels

read Help > Location XML Files

in Data Sources tab of Data Explorer select Display > Plot Location Labels > …

Drawing freely

in Data Sources tab of Data Explorer select Display > Draw freely…

exercise drawing and annotation by using Help > Drawing Controls 
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Exercise 18: Google Earth overlay

Image needs to projected in World (procedure will do it)

save image with View > Capture > Image and specify file extension *.kmz

with Google Earth installed on the system click kmz file
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Exercise 19: Suomi-NPP VIIRS imagery (not done yet)

Fort Collins fire

Al Rusayl fire

DNB scene (Ontario aurora)
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Appendix 1: Data sources for the exercises

The local datasets used in the exercises are retrieved from various archives. Orders for all 
archives can be made over the web and are free of charge. Some archives ask for 
registration (mostly simple procedures).

MVIRI OpenMTP

EUMETSAT Data Centre / GEO

https://eoportal.eumetsat.int/userMgmt/login.faces

SEVIRI HRIT and Products

EUMETSAT Data Centre / GEO

https://eoportal.eumetsat.int/userMgmt/login.faces

Notes:

xRIT datasets may be sub-sets channels and segments (including HRV).

xRIT data have to be wavelet de-compressed externally (e.g. with xRITDecompress from the EUMETSAT 
Tools website) before they can be read by the HRIT server in McIDAS-V. A wavelet de-compress procedure 
for Windows OSs is described in the Appendix (integration of decompression in local ADDE server coming 
soon).

Metop AVHRR Level 1b

NOAA CLASS

http://www.class.ngdc.noaa.gov/saa/products/search?datatype_family=AVHRR

Metop ASCAT

soil moisture - EUMETSAT Data Centre / LEO / SAF

https://eoportal.eumetsat.int/userMgmt/login.faces

wind

ftp://podaac-ftp.jpl.nasa.gov/allData/ascat/preview/L2/

Metop IASI Level 1c

EUMETSAT Data Centre / LEO

https://eoportal.eumetsat.int/userMgmt/login.faces

McIDAS-V Tutorial revised, ESCA-X-F Niamey, November 2012 37

https://eoportal.eumetsat.int/userMgmt/login.faces
ftp://podaac-ftp.jpl.nasa.gov/allData/ascat/preview/L2/
https://eoportal.eumetsat.int/userMgmt/login.faces
http://www.class.ngdc.noaa.gov/saa/products/search?datatype_family=AVHRR
https://eoportal.eumetsat.int/userMgmt/login.faces
https://eoportal.eumetsat.int/userMgmt/login.faces


Terra MODIS

 MODIS Rapid Response System

rapidfire.sci.gsfc.nasa.gov/realtime/
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Appendix 2: xRIT wavelet de-compress procedure in Windows

Straightforward procedure to wavelet de-compress a list of xRIT files:

1. Have xRIT files in one directory

2. Open a Command Prompt window and set path to the directory with the xRIT files

3. List bare file names into a text file in the same directory: dir *-C_ /b > list.bat

4. Edit file list.bat by inserting string "xRITDecompress " at beginning of each file 
name

5. Copy xRITDecompress.exe and cygwin1.dll into same directory

6. Decompress all files by running the command @list

7. Delete compressed files: del *-C_
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