
LAB: Introduction to McIDAS-V (McV) 

 

This lab shows some of the basic functionalities of McV, including opening files, displaying different channels, 

changing projection, etc. At the same time, we will briefly analyze a convective cloud system over South Africa 

/ Botswana with Meteosat -8 (MSG) SEVIRI and Meteosat-5 MVIRI data. 

 

The actual official version of McV is currently version 1.9. You should download it from the McV web 

page: https://www.ssec.wisc.edu/mcidas/software/v/download/ and install on your computer. You can also 

use version 1.8. With both versions you should be able to display GOES-16 ABI data, together with all other 

data necessary for the labs.  

 

In McV you have different ways of opening satellite data, like local or remote ADDE servers, so-called 

bundles or simply opening a file with Hydra (Hydra is integral part of McV). In this lab, we will open the data 

by using local ADDE servers, just like you would do on a Eumetcast receiving station (where the MSG data is 

locally available in HRIT format). 

 

Here are step-by-step instructions for this lab (key questions are in yellow): 

 

1. Start McIDAS-V 

a. Open McIDAS-V by double-clicking on the runMcV.bat file in the McIDAS-V-System directory 

(or the McV icon, if created on the Desktop). 

 

The opening of McV may take a bit longer (depends on PC power). Two windows will open:  the McIDAS-V 

map window (display window) and the Data Explorer window (data and channel selection window). 

 

2. Set local ADDE servers  

 

a. In the McIDAS-V map window, select Tools → Manage ADDE datasets 

 
b. Select the Local Data tab 

c. Select the MSG Dataset (with a new installation the table will be empty so you will have to enter all 

Datasets) – make sure to point to the folder where you have the data saved 

d. Click Add New Dataset 

  
 

https://www.ssec.wisc.edu/mcidas/software/v/download/


 

e. Fill in the required input as per table below. These are the data you will need for this lab. You can 

always add new datasets by clicking on ADD New Dataset or change the input to created ‘servers’ 

by clicking on Edit Dataset. 

 

 
 

f. Click OK when you are done. 

 

3. Install RGB Plugin 

 As you will be displaying RGB images, if you have a new installation of McIDAS you will need to enable     

   RGB-Eumetsat plugin: 

a. In the McIDAS-V map window, select Tools → Plugins → Manage 

b. Navigate to Miscellaneous in the list 

c. Click on the  next to RGB-Eumetsat 

You will need to restart McIDAS-V to make the installation effective. Since you don’t need the RGB 

plugin for this lab, you can just continue working and the installation will become effective when you 

close the program. 

 

4. Open MSG SEVIRI IR10.8 image (SEVIRI channel 9) 

a. In the Data Explorer window, select the Data Sources tab 

b. Select Imagery under Satellite in the panel on the left side  

c. Select Server: <LOCAL-DATA>  

d. Select the Dataset: MSG 

e. Click Connect and wait 

f. Select the Image Type: Channels 1-11 

g. Go to the Absolute tab and select the image at 2005-11-06 14:00:00 UTC 

h. Click Add Source 

i. In the Field selector tab, select Channels 1-11 in the Data Sources panel and then 10.8 um IR 

Surface/Cloud-top Temp → Temperature under the Fields panel and wait (Note: for IR images, 

we always select Temperature. Raw is to display the original counts (0 to 1023) and Radiances 

would display the radiance data (converting the counts with calibration info to radiances). 

j. Select Imagery → Image Display in the Displays panel 

k. Select the Advanced tab and put the Magnification slider to the maximum (1) 



 
l. Go to the Region tab and select a large area, from pole to pole, roughly to encompass both Europe 

and Africa. You can do this by holding down the Shift key and dragging the area with the left 

mouse button. You can also zoom in by using the mouse wheel. 

m. Click Create Display, wait 

n. Change the range of the displayed IR image: right-click the colour bar and select Change Range. 

Change the range from 190 to 300 K and click OK. 

o. Zoom in on South Africa (right mouse button to drag, mouse wheel to zoom in) 

p. Check the result: look at the IR image in the McIDAS-V window. The inverted IR image should be 

displayed as in the image below. Check the info given in the McIDAS-V window.  

 
q. Tick on and off the background layer to switch the map on and off 

 

5. Change the projection and enhance the IR image 

a. The current projection is the simple equidistant Lat/Lon projection (Plate Carrée), which is the best 

choice if you want to export the images to Google Earth. Change the projection of the image to the 

original (MSG) satellite projection by selecting Projections → From Displays → Image (MSGT) 

Projection from: Image Display 

 
b. Now the IR image should be a rectangular image (as defined by the lines and columns of the 

original MSG image).  

c. Change the projection to different ones by selecting Projections → Predefined → … 

d. As the image zooms out automatically, strongly zoom in on the convective clouds over South Africa 

e. Now, change the range of the displayed IR image to 190 to 210 K, to only see the coldest clouds. 



The image should look like this: 

 

 
f. Now, find the coldest IR pixel in the image: hold down the middle mouse button (the wheel).  

g. A white cross appears at the cursor position, and the lat/lon and BT information appears on the 

bottom of the display window, as in the image below. Note that in order to see the readings, the 

window should not be full screen. 

 
h. Move the cursor across the image and find the coldest pixel of the SEVIRI IR image. Note the value. 

Is it below 190 K? 

i. Let us put a colour bar on the IR image 

j. Left-click on the layer name (Channels 1-11 (All Bands)) in the Legend panel.  

k. The Layer Controls tab in the Data Explorer window pops up. See the image below: 

 
l. Click on the info button, as indicated in the image 

m. A new window with different tabs will pop up as shown below 



 
n. In the Colour Scale tab make the colour table visible and change the font as indicated above 

o. Click Apply and when you like the result click OK. The image should look like this (with the 

colour bar on top): 

 
p. Now let us change the range back to 190 to 300 K and create a colour enhancement of the IR image 

q. Right-click the colour bar and select Change Range. Change the range from 190 to 300 K and click 

OK. 

r. Right-click again the colour bar and select System → Legacy → Setvak (see Annex 1 for info 

about this colour table) 

s. Zoom out to see South Africa and Botswana; the image should look like this: 

 
t. Finally, save the image. To do so, go to the McIDAS-V window and navigate to View → Capture 

→ Image (see the image below) 

 
u. Save the image on your local system (where you find suitable) in the directory “Images” with 

filename:20051106_1400_msg_ir108_col.png 

(please, you must type .png as the extension of the file to get PNG images!) 

v. Click Save 



 

Question: conceptually, what feature are the cold storms over northern South Africa and southern Botswana? 

Can you see any structures? What do you think is the suitable temperature range for the global view? 

 

Note: To answer these questions, you may display the VIS0.8 and WV6.2 images. And, you could display the 

Airmass RGB (AIRM), Dust RGB (DUST) and the Severe Convection RGB (SCON). In the next Labs you will 

learn how to display RGB images. 

 

6. Display the SEVIRI HRV Image and compare to IR10.8 image 

a. In the Data Explorer window, select the Data Sources tab 

b. Select Imagery under Satellite in the panel on the left side  

c. Select Server: <LOCAL-DATA>  

d. Select the Dataset: MSGHRV 

e. Click Connect and wait 

f. Select the Image Type: HRV Channel 

g. Go to the Absolute tab and select the image at 2005-11-06 14:00:00 UTC 

h. Click Add Source and wait  

i. In the Field selector tab, select 0.7 um Broadband visible → Reflectivity under the Fields panel 

and wait 

j. Select Imagery → Image Display in the Displays panel 

k. Select the Advanced tab and put the Magnification slider to the maximum  

l. Go to the Region tab and select a large area from Namibia to Madagascar 

m. Click Create Display, wait 

 

Check the result: the HRV image should be displayed on top, but it is relatively dark. Question: Why is it so 

dark? 

n. Change the range of the displayed HRV image: right-click on the colour bar → Change Range, 

from 0 to 60 (% reflectance). The image becomes much brighter! 

 

Zoom on the convective storms and toggle the HRV and the IR images to compare the images. What extra 

features do you see in the HRV image that you cannot see in the IR image (see e.g. image below)? 

  

o. Now, zoom to Madagascar and you can see that the HRV image is cut off as shown in the image 

below. Why is the image black east of the red line (think of the time of the image 14 UTC)? 



 
p. Save the HRV image: in the main window, navigate to View → Capture → Image and save the 

image 

q. Click Save 

 

7. Display Met-5 infrared image (for comparison) 

a. In the Data Explorer window, select the Data Sources tab 

b. Select Imagery under Satellite in the panel on the left side  

c. Select Server: <LOCAL-DATA>  

d. Select the Dataset: MET5 

e. Click Connect and wait 

f. Select the Image Type: MVIRI 

g. Go to the Absolute tab and select the image at 2005-11-06 14:30:00 UTC 

h. Click Add Source and wait  

i. In the Field selector tab, select 11.5 um IR Surface/Cloud-top Temp → Temperature under the 

Fields panel and wait 

j. Select Imagery → Image Display in the Displays panel 

k. Select the Advanced tab and put the Magnification slider to the maximum  

l. Go to the Region tab and select the region that includes South Africa and Madagascar 

m. Click Create Display, wait 

n. Go to the McIDAS-V window to see the result 

o. Change the range of both IR images (Met-5 MVIRI and Met-8 SEVIRI) to 190 to 300 K and use 

the Setvak colour table for both images. 

 

Zoom on the convective storms over northern South Africa. Toggle the Met-5 (MVIRI) and the Met-8 

(SEVIRI) IR images. As you can see, the (cold) clouds are not in the same position. Question: why? 

Compare the IR brightness temperatures of the two IR images. Hold down the mouse wheel and read the values. 

Are they the same? Which are higher? 

 

p. Now, remove the Met-5 MVIRI IR image by clicking on the remove button as indicated below 

 

 
q. And last but not least, change the background map a bit 

r. Click on the text of the Default Background Maps label 



s. That will open the Layer Controls tab in the Data Explorer window 

t. In the Maps tab, tick off World Coastlines and World Country Outlines and tick only the World 

Country Outlines (Hi-Res) and select cyan as colour. This map database has also some islands 

included! 

u. In the Lat/lon tab, create a lat/lon grid of 5 degrees interval (change the Interval for both Latitude 

and Longitude to 5). Press Enter in order to approve the changes. The result should look like this: 

 
v. Save the IR image: in the main window, navigate to View → Capture → Image and save the image 

w. Click Save 

 

 

8. Display Met-5 and Met-8 infrared images on 3D Globe 

a. In the McIDAS-V window, select File → New Display Window → Globe Display → One Panel 

b. A new McIDAS-V window will appear, see example below 

 
c. Go to the Data Explorer window and load the Met-8 (MSG) IR10.8 image for the same time at full 

resolution for the whole Met-8 disk (if you do not remember how to do that, see instructions above) 

d. Rotate the Globe to see Africa (hold Control key and use right mouse button) 

e. Set the range again to 190 to 300 K 

f. Load the Met-5 IR image (full disk) and set the range also to 190 to 300 K. The display should look 

like this: 



 
g. The Met-5 image is on top of the Met-8 image. You can change this order by: right-click on the 

label of the Met-8 image and select View → Bring to Front 

h. Rotate the Globe and zoom as you like. How far east does Met-5 cover (where is the nadir point)?  

Is Beijing included in the image? 

i. You can create an animated rotation of the Globe by holding the Control key and swiping the right 

mouse button across the image (like you do on tablet PCs with your finger) 

 

 

 

Annex 1: How to create the Setvak IR colour table 

 

For info, check the Convection Working Group website. 

 

 
a. Open an IR image and set range from 200 to 300 K 

b. Right-click on the colour bar of the IR image, select Edit Colour Table 

c. A new window (Colour Table Editor) will pop up 

d. Top Menu: select Color Tables → System → Inverse Grey Scale 

e. Add 5 new breakpoints in the colour table by right-clicking on the colour bar Add Breakpoint → 

At Data Point → Value = 208, Click OK 

f. Repeat this for breakpoints at 216, 224, 232 and 240 K. 

g. Lock all breakpoints: right-click on the breakpoint → Lock Breakpoint. This is to prevent you from 

moving/changing the breakpoints. The Colour Table Editor should look like this: 

https://cwg.eumetsat.int/


 

h. Then, select breakpoint 200 K (left-click) 

i. Select the colour for this breakpoint by clicking on the RGB tab 

j. Select Red=131, Green=0, Blue=0 (dark red), see screenshot below: 

 

 

k. Do the same for the breakpoint 208 K (255,0,0) red 

l. Do the same for the breakpoint 216 K (255,255,0) yellow 

m. Do the same for the breakpoint 224 K (0,255,255) cyan 

n. Do the same for the breakpoint 232 K (0,0,255) blue 

o. Do the same for the breakpoint 240 K (0,0,131) dark blue 

p. You should now see some nicely coloured lines in the colour bar window (see below) 

 

q. Now, to interpolate between these breakpoint colours, you have to: 

i. Right-click on the 208 K breakpoint, and select from the drop down list: Edit Colours → 

Interpolate → Left 

ii. Do the same for the 216 K, 224 K, 232 K and 240 K breakpoints 

r. Now, let us also enhance the warm part of the colour table (240 to 300 K) by selecting the 240 K 

breakpoint again (left-click) 

s. Change the colour to white (RGB 255,255,255) 

t. Right-click on the 300 K breakpoint, and select from the drop down list: Edit Colours → 

Interpolate → Left. The colour bar should look like this: 

 
 

u. Save the new colour table: Colour Table Editor window: File → Save As → Select name 

 


