
LAB – Investigating Wildfires with SEVIRI and MODIS 
 

Here are the goals of this lab: 

 

1. New McIDAS-V skills: 

a. How to open a bundle 

b. How to compare several bands of satellite imagery both visually and quantitatively 

c. How to set color scale ranges and change enhancement tables 

d. How to use a Formula (this lets you do quantitative calculations with satellite data!) 

2. Key concepts: 

a. Interpretation of visible and infrared imagery of wildfires, smoke and burn scars 

b. Brightness temperature 

c. Differences between 3.9µm and 10.8µm channel when looking at fires 
 

Here are step-by-step instructions for this lab (key questions are in yellow): 

 

PART I: 

1. Read in the bundle which includes MSG SEVIRI data to start the lab: 

a. Open McIDAS-V 

b. In the Map Window, click File → Open File 

c. Locate a file called “fires_2tabs.mcvz” under the directories McV_data → bundles and click 

Open 

d. Click OK a few times, leaving the default options alone 

e. In the Select Input window, select 0 (minrefl) and 40 (maxrefl) and click OK 

f. Wait, it takes some time to load this “big” bundle 

g. The display should look like this (the VIS0.6 image is the top image): 

 

h. Try to find out what type of weather situation do we have? 

 

2. Many channels and RGBs of SEVIRI imagery have now been loaded and are displayed in 2 separate tabs: 

the  29 Aug 2008, 09:00 Z tab and the 31 Aug 2008, 13:00 Z tab.  Here is a list of everything you have: 

i. 0.6 um (visible) reflectance 

ii. 0.8 um (visible) reflectance 

iii. 3.9 um brightness temperature 

iv. 10.8 um brightness temperature 

v. Red/Green/Blue (RGB) “Natural Colour” composite 

vi. Red/Green/Blue (RGB) “Dust” composite 

You can choose which display is visible at any moment by clicking the checkboxes on the right side of 

the map window. 

 

3. Look at 29 Aug 09:00 UTC visible imagery 

a. First display the RGB Natcol Composite (see image below)



 

Questions: Can you identify the features 1 to 5? Are these 5 features also visible in the infrared channels / Dust 

RGB? 

b. Focus on feature 2 in Botswana and have a look at the VIS0.6 and VIS0.8 channels. Change the 

range of these two channels to 0 to 25 % reflectance. Which channel does show a better contrast 

for feature 2? Could this dark feature be flooded area? 

c. Display the HRV channel 29.08.2008 at 09:00 UTC for Botswana to see more details of feature 

2 and compare it to the other VIS channels. The description of how to display the HRV images 

(from local data) is given in Lab 1. Use the same range (0 to 25%) as for the VIS0.6 and VIS0.8 

images. Is the HRV image brighter or darker than the other VIS images? 

 

4. Look at the 29 Aug 09:00 UTC infrared imagery 

a. Now take a quick look at the IR3.9 and IR10.8 Brightness Temperature infrared imagery 

b. Enhance these IR images by changing the temperature range: 273 to 336 K for both the IR3.9 

image and the IR10.8 image 

c. Now both IR image have the same colour enhancement table so that you can visually compare 

the values 

d. Focus on the feature 2 in Botswana (see IR3.9 image below) 

 

 
e. Compare the 2 IR images qualitatively by toggling the images: which image has higher 

brightness temperatures? Why? Which IR image better detects thin Cirrus? Why? What are the 

black spots in the IR3.9 image? 

f. Please, toggle the IR3.9 and the RGB Natcol images:what do you think is the wind direction in 

this part of Botswana? For this question, check the position of the hot spots and the eventual 

presence of smoke plumes! 

g. Now, let us create a colour table where the black spots appear in colour: Right-click on the 

colour bar of the IR3.9 image, select Edit Colour Table 



h. A new Colour Table Editor window will pop up 

i. Add a new breakpoint in the colour table by right-clicking on the colour bar and selecting Add 

Breakpoint → At Data Point → Value = 325, and then clicking OK 

j. Then, select the new breakpoint 325 K by left-clicking on the symbol 

k. Select the colour for this breakpoint by clicking on the RGB tab 

l. Select Red=255, Green=255, Blue=0 (which makes yellow), see screenshot below: 

m. Do the same for the breakpoint 336 K and select Red (255,0,0) 

n. Now, to interpolate between these breakpoints, you have to: Right-click on the 336 K 

breakpoint, and select from the drop down list: Edit Colours → Interpolate → Left 

o. The colour bar should look like this: 
 

p. Save the new colour table by clicking File → Save As → Select name (e.g. “Hotspots”) 

q. Click OK 

r. The black spots now appear in colour: from yellow (hot pixels) to red (very hot pixels). This 

makes them more evident. Can you see other areas with hot pixels? 

 

5. (Extra lab) Difference between IR3.9 and IR10.8 imagery (daytime) 

a. To compare the brightness temperature values quantitatively, you can click the middle mouse 

button on any pixel. This will allow you to compare the actual values of each pixel. 

b. Compare the 2 channels for: Namib desert, Kalahari, vegetated land, burned land, hot spots, 

water (ocean), thin cirrus clouds, thick ice clouds, low level water clouds. Create a table. For 

each target try to explain the difference. 

c. Make a “difference image” of the IR3.9 and IR10.8 channels. This will nicely highlight the 

pixels that contain an actively burning fire 

d. In the map window, select File → New Display Tab → Map Display → One Panel 

e. A new McIDAS-V window tab will appear (untitled) 

f. Rename this new tab to “Difference” (double click the tab for renaming) 

g. Go to the Data Explorer window 

h. Click the Field Selector tab 

i. On the left side of the window, click Formulas 

j. In the Fields panel, click the arrow next to Miscellaneous and select Simple difference a-b 

k. Select Imagery →Image Display in the Displays panel 

l. Click Create Display, and a new window pops up 



m. For Field a select the first M10 (All Bands) → 3.9 um IR (see example below) 

n. For Field b select the first M10 (All Bands) → 10.8 um IR (see example below) 

o. Click OK. All we have done here is created an image of the difference between the IR3.9 and 

IR10.8 brightness temperatures! 

p. Change the range of the difference image to -5…+30 K 

q. Now, the difference image should look like this: 

r. The hot pixels in Botswana have a large positive difference IR3.9 – IR10.8. Why? Thin Cirrus 

clouds also have a positive difference.  Why? 

s. Explore the difference image in more detail. Use the middle mouse button to quantitatively 

determine the brightness temperature difference between the IR3.9 and IR10.8 channels. What is 

the largest difference you can find? 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



PART II: 

 

6. Situation two days later on 31 August 13:00 UTC  - second tab in McV 

a. First, change the ranges of the displayed VIS and IR images: 273 K to 336 K for IR, 0 to 25% 

for VIS images 

b. Then display/toggle the RGB Natcol and Dust Composites (see image below) 

 

c. Can you identify feature 1? What synoptic situation do we have? 

d. You may display the WV6.2 image (from local data) to check the synoptic situation (using 

conceptual model analysis) 

e. What is the surface wind situation over Botswana, northern RSA and Swaziland? Has it changed 

compared to the previous case (29 August)? Are there areas with strong surface winds? How can 

you confirm this (hint: check the Dust RGB)? 

f. Now focus again on the dark area in central Botswana (see image below) and look at the RGB 

Natcol, the IR3.9 and the IR10.8 images 

 

g. Has the wind direction changed compared to two days ago? What are the red dots in the Natcol 

RGB? 

h. Zoom out and select the IR3.9 image: Where can you detect new hot spots? Which are the hottest 

pixels (in IR3.9)? Check also the IR10.8 and the Natcol RGB. 

i. Some hot pixels form lines of several east-west pixels (see screenshot below). Why? Are these 

fires which extend east-west over many kilometers? Check again also the IR10.8 and Natcol 

RGB! 



 
 

7.  Situation one day later on 1 September 5:00 UTC 

a. We have to open the images manually (from local data on) as they are not    included in 

the bundle that we have opened 

b. In the McIDAS-V window, select File → New Display Tab → Map Display → One Panel 

c. A new McIDAS-V window tab will appear (untitled) 

d. Rename this new tab to “1 Sep 5:00Z” (double click the tab for renaming) 

e. In the Data Explorer window, select the Data Sources tab 

f. Select Imagery under Satellite in the panel on the left side 

g. Select Server: <LOCAL-DATA> 

h. Select the Dataset: MSG, click Connect and wait 

i. Select the Image Type: Channels 1-11 

j. Go to the Absolute tab and select the image at 2008-09-01 05:00:00 UTC 

k. Click Add Source 

l. In the Field selector tab, select SEVIRI RGB standard → NCOL (natural colours)  

m. Select 3 Color (RGB) Image in the Displays panel 

n. When prompted: For minrefl put 0% and for maxrefl put 40%. 

o. Choose corresponding channels / RGB components (B-R-G in fact) from list of Channels 1-11 

(Reflectivity) 

p. Select the Advanced tab (last channel only) and put the Magnification slider to the maximum 

q. Go to the Region tab and select a large area that includes South Africa and Madagascar 

r. Click Create Display. This is an early morning image, which should look pretty dark, like this: 

 

s. What is the bluish (cyan) feature over the Ocean (Mozambique Channel)? 

t. Try to enhance the RGB image by re-creating the RGB with a range of 0 to 15%. Has the 

contrast become better? 

u. Now, open also some infrared images: IR3.9, WV6.2, IR10.8 and Dust RGB (for the same area) 

v. Is the bluish feature over the Ocean also seen in one of the infrared channels or the Dust RGB? 

Why? Why not? 

w. Looking at the WV6.2 image, what is the synoptic situation of this case? Where is the jet? 

Where is the upper-level trough? What is the wind situation at low levels? 

 

 



8.  Multi Panel display of the Natural Colour RGB 

a. To understand why smoke plumes appear bluish (cyan) in the Natural Colour RGB we may open 

the RGB and its 3 components in a 4-panel display 

b. In the map window, select File → New Display Tab → Map Display → Four Panels 

c. A new McIDAS-V window tab will appear (untitled) 

d. Rename this new tab to “4-Panel Natcol RGB” (double click the tab for renaming) 

e. Select (left click) the upper left panel. A blue frame appears around the selected panel (see 

example below) 

 

f. Go to the Data Explorer window, and in the Field Selector tab, select SEVIRI RGB → 

NCOL (natural colors) 

g. Put Magnification to 1 and select a small region around the Mozambique Channel 

h. For the reflectivity range select again 0 to 15%, zoom on the Mozambique Channel (note that all 

4 panels zoom at the same time), the image should look like this: 

 
i. Now let us load the 3 solar channels in the 3 remaining panels 

j. Select the upper right panel and load the VIS0.6 channel (reflectivity) 

k. Select the lower left panel and load the VIS0.8 channel (reflectivity) 

l. Select the lower right panel and load the NIR1.6 channel (reflectivity) 

m. Change the range for all three images to 0 to 15%: to display the legend of the displays, you 

have to click on the View menu of the corresponding panel (upper left corner of the panel) and 

select Display → Float Legend and then change the range by right-clicking on the legend and 

selecting Change Range 

n. The 4-panel display should look like this. 



 

o. Now that we have displayed the Natcol RGB and its 3 inputs (Red=NIR1.6, Green=VIS0.8, 

Blue=VIS0.6), can you explain why the colour of the smoke plume is cyan? 

p. Which channel has strongest signal for smoke, which the weakest? 

 

9.  Comparison of SEVIRI and MODIS images 

 

a. To prepare for MTG (Meteosat Third Generation), let us look at the same scene (29 August) with 

high-resolution (1 km) MODIS data 

b. First you need to add MODIS data (Tools → Manage ADDE Datasets → Local Data → Add 

New Dataset) – same as in the Introduction LAB 

c. Insert Dataset, Image Type and choose Format as in the image below: 

 

   
 

d. In the map window, select File → New Display Window → Map Display → One Panel 

e. A new McIDAS-V window will appear (untitled) 

f. Rename this new tab to “MODIS” (double click the tab for renaming) 

g. In the Data Explorer window, select the Data Sources tab 

h. Select Imagery under Satellite in the panel on the left side 

i. Select Server: <LOCAL-DATA> 

j. Select the Dataset: MODIS, click Connect and wait 

k. Select the Image Type: Level 1B Data 

l. Go to the Absolute tab and select the image at 2008-08-29 08:55:00 UTC 

m. Click Add Source 

n. In the Field selector tab, select 3.7882 um → Temperature (MODIS Band 20, IR3.7) 



o. Select Imagery → Image Display in the Displays panel 

p. Select the Advanced tab and put the Magnification slider to the maximum (1) 

q. Go to the Region tab and select an area that includes Botswana 

r. Click Create Display, wait 

s. Create an appropriate “fire” enhancement table for this MODIS IR3.7 image, the result should 

look like this: 

 
 

t. Zoom on the fires in Botswana and compare to the SEVIRI IR3.9 image: which instrument 

detects more fires? 

u. The MODIS instrument has 4 bands in the IR3.9 region. Let us display the “fire” band (band 21) 

v. In the Field Selector tab of the Data Explorer window, select 3.9921 um → Temperature 

(MODIS Band 21, IR3.9) and Create Display 

w. Again, create an appropriate enhancement table 

x. What is the difference to the MODIS IR3.7 image? 

 

10. (Extra lab) Let us also display the MODIS solar bands to compare them to the SEVIRI solar bands 

a. In the Map window, select File → New Display Tab → Map Display → Four Panels 

b. In the upper left panel display the 0.4656 um → Reflectance (MODIS Band 3) 

c. In the upper right panel display the 0.6465 um → Reflectance (MODIS Band 1) 

d. In the lower left panel display the 0.8567 um → Reflectance (MODIS Band 2) 

e. In the lower right panel display the MODIS True Colour RGB 

f. In the Field Selector tab of the Data Explorer window select Formula in the left panel and then 

in the Fields panel select Imagery → Three Color (RGB) Image (Auto-scale) 

g. Select RGB Composite in the Displays panel and click Create Display 

h. A new input window pops up 

i. For red select Level 1B Data → 0.6465 um → Reflectance 

j. For green select Level 1B Data → 0.5537 um → Reflectance 

k. For blue select Level 1B Data → 0.4656 um → Reflectance 

l. Click OK, the 4-panel display should look like this: 



 

m. Play around with the enhancement tables of all 4 images 

n. In which MODIS band is smoke best detected? Is MODIS better than SEVIRI for smoke 

detection? 

 


