
Lab: Tuning of Dust RGB for AHI / ABI 

 

 

1.   McIDAS-V skills: 

a. Display data from a remote server 

b. Create RGB images with Imagery tool 

c. Create channel differences 

d. Fine tuning RGB products 

e. Comparing infrared bands 

 

2.   Key concepts: 

a. Ash and dust clouds in infrared spectral range 

b. Cloud phase in infrared spectral range 

c. New infrared channels on AHI / ABI 

d. Fine-tuning of Dust RGB 

e. Thickness of dust clouds 

f. Convective clouds in infrared and visible 

 

The Airmass RGB and the Dust RGB are considered to be the most important RGB products for operational 

weather forecasting (24-h capability). As regards the Dust RGB for MSG SEVIRI, the bands IR8.7, IR10.8 and 

IR12.0 have been combined to monitor dust and ash, but it is also very useful for detecting thin cirrus clouds, 

cloud phase, low level clouds and low level moisture boundaries (see moisture lab).  

 

The standard recipe of the SEVIRI Dust RGB is: 

 

Red: IR12.0 – IR10.8, range -4 to +2 K, Gamma = 1.0 

Green: IR10.8 – IR8.7, Range 0 to +15, Gamma = 2.5 

Blue: IR10.8, range 261 to 289 K, Gamma = 1.0 

 

The red component of the Dust RGB is used for (or contributes to): 1) discrimination of dust/ash clouds from 

ice and water clouds, 2) discrimination of thick and thin clouds (for mid and high level clouds, does not work 

for low level clouds), 3) detection of moisture boundaries (retrieval of Total Precipitable Water (TPW), which 

mainly depends on low level (boundary layer) moisture. 

 

The main use of the green component is 1) cloud phase detection (water/ice, works day and night), but it also 

contributes to 2) identifying optical thickness of clouds, 3) detection of dust/ash clouds (over desert surfaces) 

and 4) moisture features. 

 

The blue component represents cloud top temperature, so its main use is for cloud height determination. For 

example, volcanic ash plumes (from major eruption) are often in the upper troposphere or lower stratosphere 

(relatively cold), so they have a low blue contribution (typical Dust RGB colour is red). On the contrary, dust 

clouds (e.g. post-frontal dust) are often travelling at low levels (relatively warm), thus they have a higher blue 

contribution (typical Dust RGB colour is magenta). 

 

Depending on the situation (viewing angle, airmass / moisture, summer/winter), these ranges can be changed, to 

enhance certain features. For example, the Ash RGB is a modified version of the Dust RGB to better 

discriminate high level ash clouds from ice clouds and to enhance SO2 clouds (frequently emitted by volcanic 

eruptions, see ash labs). 

 

The new generation of geostationary weather satellites (Himawari-08, GOES-16, MTG) will have slightly 

different infrared channels which poses the question of tuning the Dust RGB to the new channels.  

 



In this lab, we will try to tune the Dust RGB for the AHI (on Himawari-08 and Himawari-09) and ABI (on 

GOES-16, 17 …) instruments. These instruments (identical instruments, but channels slightly different) have 4 

(instead of 3) bands in the IR window regions (8.5 and 10 to 12 microns). These are (for AHI): band 11 - IR8.6, 

band 13 - IR10.4, band 14 - IR11.2 and band 15 - IR12.4 (SEVIRI has IR8.7, IR10.8 and IR12.0). 

 

See here below the filter functions (spectral response functions (SRF)) of the AHI infrared bands. 

 

 
 

With these 4 window channels in the infrared, the question comes up which combination of these 4 channels 

should be used to device the Dust RGB, remembering that the main scope of the Dust RGB is to detect dust / 

ash clouds and to discriminate between water and ice clouds (cloud phase). Without thinking too much, we tried 

the following recipe: red = IR12.4 – IR10.4, green = IR10.4 – IR8.6, blue = IR10.4, but this approach was not 

the best one. Please, try yourself to find the optimal tuning of the Dust RGB for AHI and ABI. 

 

I. Tuning of the red component of the Dust RGB for AHI / ABI 

 

In the 10-12 μm “infrared window” region, ash and dust clouds generally become more transparent to radiation 

with increasing wavelength. The opposite is true for liquid water clouds, ice clouds, and background 

atmospheric gases (mainly H2O and CO2).  The magnitude of the slope in cloud transmissivity is largely 

dictated by the effective particle radius. This can be seen in the following figure, where andesite and rhyolite are 

volcanic (ash) materials. The Spectral Response Functions of AHI bands 13 to 16 are shown by red curves. 

Note that band 16 – IR13.3 is not a window channel (CO2 absorption). 

 



 
 

From this figure it follows that the combination of AHI/ABI bands 13 (10.4 μm) and 15 (12.4 μm) should be 

better suited for both qualitative (RGB) and quantitative volcanic ash detection techniques. BUT: is this always 

the case in practice? 

 

1. Display Met-8 SEVIRI imagery on 3 May 2017 (over Tibet area) 

 

a. Open McIDAS-V (version 1.5) 

b. In the McIDAS-V window, go to File → Open File 

c. Open the bundle “seviri_20170503_met08.mcvz” in the Data → bundles directory (wait) 

d. If asked, select Merge with active tab(s) (default option) and Write to temporary directory 

(default option) 

e. Click OK when error message appears 

f. In the Select input window select minrefl 0 and maxrefl 20 

g. Wait until all frames are loaded, the display window should look like this (Natural Colors RGB 

image is in front): 

 

 
 

h. First, inspect the Natural Colours RGB: is this a morning or evening image? Can you identify areas 

with dust? 

i. Now, move to the Dust RGB and toggle the two images. Which dust clouds do you see? 

j. From the colour of the dust clouds and from its opaqueness (can you see surface features through 

it?) can you say something about the thickness of the dust clouds? 

k.  

 

2. Display Him-08 AHI infrared images for the same case 

 

a. In the McIDAS-V window, go to File → Open File 

b. Open the bundle “ahi_20170503_him08_ir.mcvz” in the Data → bundles directory (is a bit slow in 



opening!) 

c. If asked, select Merge with active tab(s) (default option) and Write to temporary directory 

(default option) 

d. Wait until all frames are loaded, the display window should look like this (IR12.4 image is in front): 

 

 
 

e. All 4 IR window bands of AHI have been loaded, with the range 180 to 320 K (standard range). Can 

you see the dust clouds in these IR images? You may enhance the images by selecting different 

ranges. 

f. Read some IR values for thick, high clouds, mid level clouds and cloudfree areas (land, Ocean). For 

each scene, which IR channel has the highest brightness temperature? 

g. Now, we want to calculate the difference image IR12.4-IR10.4. For this, unfortunately, we cannot 

use the data of the bundle (McV 1.5 and 1.6 has a bug as regards displaying data from a bundle). So 

we will read the Him-08 data for this case (3 May 2017) from the Wisconsin archive of satellite data 

(remote server). 

h. Go to the Data Explorer click on satellite imagery (left) and select the geoarc.ssec.wisc.edu server. 

Select the AHIM08 dataset and connect to the server.  

i. As Image Type select FD (Full Disk) data and select the archive day 03-May-2017. Click ok and 

wait (it takes time to connect and read the time slot information). 

j. The Absolute tag should be highlighted. Select the image from 12:00 UTC and click on Add 

Source. Wait. The Data Explorer moves to the Field Selector where you see all 16 bands of the 

AHI instrument on Him-08 (see screenshot below). 

 

 
 

k. For calculating a channel difference, we need to go to Formulas (left). In the Fields panel, select 

Image Filters (remember it is Miscellaneous in McV 1.4) → Simple difference a-b 

l. Select Imagery → Image Display in the Displays panel 



m. Click Create Display, and a new window pops up 

n. For Field a select 2nd Full Disk Himawari → 12.4 um → Temperature (wait) 

o. For Field b select 2nd Full Disk Himawari → 10.4 um → Temperature (wait) 

p. Important: before you click OK, expand the Field Selector window so that you see the Region and 

the Advanced tabs (see screenshot below). FIRST: set the Magnification slider to 1 (max resolution). 

 

 
 

q. Then, select the Region (shift left mouse, China and India) and now click OK. 

r. The difference IR12.4 – IR10.4 is now displayed as top image.  It looks greyish as the range is not 

correct. Change the range to -4 to +2 K. 

s. Change the label of the displayed image to the “IR12.4 – IR10.4” 

t. Now, the difference image should look like this: 

 

 
 

u. Thin dust and ash clouds have a positive IR12.4 – IR10.4 difference and appear whitish in this 

difference image; thin water and ice clouds have a negative difference and appear dark (black) in 

this image. Thick clouds have differences around 0 K and appear light grey. 

v. Toggle the Met-08 Dust RGB and the Him-08 difference image: do they correspond as regards dust 

detection? What is the largest difference IR12.4 – IR10.4 that you can find? From the values that 

you find, can you guess what is the height of the dust clouds (low, medium, high)? 

 

 

3. Calculate the other IR differences to check which difference gives the best results for dust detection (in a 

qualitative way) 

 

a. As above, calculate the IR12.4 – IR11.2 and the IR11.2 – IR10.4 differences and display them with 

the same range (-4 to +2 K). Keep max resolution and the same Region (already set). 

b. Rename the difference images to IR12.4 – IR11.2 and IR11.2 – IR10.4. 

c. Toggle all three difference images. Which difference gives the best results as regards dust detection? 

d. Read the difference values for various scenes (press middle mouse button, see screenshot below): 

thick & thin dust, cloudfree land, cloudfree Ocean, low, mid, high clouds. What rule do you note, 

are the differences adding up (see example below)? 

 



 
 

4. Generate the Dust RGB for the Him-08 ABI image and compare to the Met-08 SEVIRI Dust RGB 

 

a. Go to the Field Selector tab in the Data Explorer window 

b. Select Formulas in the Data Sources panel 

c. In the Fields panel, select Imagery → Three Color (RGB) Image (Auto-scale) 

d. Click Create Display, and a new window pops up 

e. For Field red select Formulas → Image Filters → Simple Difference 

f. For Field green select Formulas → Image Filters → Simple Difference 

g. For Field blue select 2nd Full Disk Himawari → 10.4 um → Temperature (wait) 

h. Click OK 

i. A new window pops up (for red difference) 

j. put Field a Full Disk Himawari → 12.4 um → Temperature (wait) 

k. Put Field b Full Disk Himawari → 10.4 um → Temperature (wait) 

l. Click OK 

m. A new window pops up (for green difference) 

n. Put Field a Full Disk Himawari → 10.4 um → Temperature (wait) 

o. Put Field b Full Disk Himawari → 8.6 um → Temperature (wait) 

p. The RGB image is displayed in the McIDAS-V window and the Layer Controls in the Data 

Explorer window, see screenshot below. 

 

 
 

q. To generate the Dust RGB, change the ranges of all three color beams: -4 to +2 for red range, 0 to 

+15 for green, and 261 to 289 for blue. Also, set the green Gamma to 0.4 (which is actually 2.5). 

Each input value has to be confirmed by Enter.  See final settings below. 

 

 
 

r. The Him-08 “Dust RGB” should look like this: 

 



 
 

Question: which features can you see in this RGB? Toggle the Met-08 and Him-08 Dust RGBs: what 

differences do you see, as regards dust clouds, as regards water and ice clouds and as regards cloudfree areas?  

 

 

II. Tuning of the green component of the Dust RGB for AHI / ABI 

 

As already mentioned, the main use of the green component is 1) cloud phase detection (water/ice, works day 

and night), but it also contributes to 2) identifying optical thickness of clouds, 3) detection of dust/ash clouds 

(over desert surfaces) and 4) moisture features. 

 

As regards cloud phase, water and ice clouds absorb differently in the infrared region; see the refractive index 

of water and ice (green curves) in the following figure. Remember that the imaginary part of the refractive 

index indicates the amount of attenuation when the electromagnetic wave propagates through the material 

(water/ice cloud). At around 10 micron and at around 13.5 micron water and ice have the same refractive index, 

while at around 11 to 11.5 micron there is the largest difference between water and ice.  

 

  
 

The colored curves show the spectral response functions of 3 instruments: red curves SEVIRI (2 relatively 

broad channels), magenta curves AHI (three more narrow channels) and blue curves the future FCI (on MTG, 

only 2 channels). From this figure, it appears that the AHI IR11.2 channel should be the most suitable channel 

for being used on the green beam of the Dust RGB, i.e. the IR11.2 – IR8.6 difference. 

 

This becomes a bit more evident when you blow up the above figure as shown below. The position of the AHI 

infrared bands are indicated by colored rectangles. In the following lab we will test and see which difference 

(IR10.4-IR8.6, IR11.2-IR8.6, IR12.4-IR8.6) gives the best results for cloud phase detection (and should be used 

for the green beam of the Dust RGB). 

 



  
 

5. Display Met-8 SEVIRI imagery on 17 May 2017 (over India and SE Asia) 

 

a. Close and Re-Open McIDAS-V (version 1.5) 

b. In the McIDAS-V window, go to File → Open File 

c. Open the bundle “seviri_20170517_met08.mcvz” in the Data → bundles directory (wait) 

d. If asked, select Merge with active tab(s) (default option) and Write to temporary directory (default 

option) 

e. Click OK if error message appears 

f. In the Select input window select minrefl 0 and maxrefl 80 

g. Wait until all frames are loaded; the Met-08 Natural Colours RGB image should be in front. Toggle 

to the Dust RGB, which should look like this: 

 

 
 

h. This image will be the reference for us to tune the AHI Dust RGB (green beam). Mid level water 

clouds (brownish) have a very different color than high level ice clouds (dark red). Thin ice clouds 

are black or dark blue. Also moisture features can be seen. 

i. Also the Natural Color RGB helps to identify cloud phase; ice clouds have cyan color, water clouds 

white to pinkish. Toggle the Dust RGB and the Natcol RGB: is the Natcol RGB good for cloud 

phase, where does it have problems? 

j. There is a thunderstorm over Northern India (Ganges valley): what type of thunderstorm is this? If 

you know the type (conceptual model), what can you say about the future development of this storm 

(forecast next 6 hours)? 

k.  

 

6. Create the Himawari-08 Dust RGB for the same case (with the IR10.4 channel) 

 

a. We will again read the Him-08 data for this case (17 May 2017) from the Wisconsin archive of 

satellite data (remote server). The RGBs will be generated with the same procedure as before. 

b. Go to the Data Explorer click on satellite imagery (left) and select the geoarc.ssec.wisc.edu server. 

Select the AHIM08 dataset and connect to the server. 



c. As Image Type select FD (Full Disk) data and select the archive day 03-May-2017. Click ok and 

wait (it takes time to connect and read the time slot information). 

d. The Absolute tag should be highlighted. Select the image from 06:00 UTC and click on Add 

Source. Wait. 

e. The Data Explorer moves to the Field Selector where you see all 16 bands of the AHI instrument. 

f. Go to the Field Selector tab in the Data Explorer window 

g. Select Formulas in the Data Sources panel 

h. In the Fields panel, select Imagery → Three Color (RGB) Image (Auto-scale) 

i. Click Create Display, and a new window pops up 

j. For Field red select Formulas → Image Filters → Simple Difference 

k. For Field green select Formulas → Image Filters → Simple Difference 

l. For Field blue select 2nd Full Disk Himawari → 10.4 um → Temperature (wait) 

m. Important: before you click OK, expand the Field Selector window so that you see the Region and 

the Advanced tabs. FIRST: set the Magnification slider to 1 (max resolution). 

n. Then, select the Region (shift left mouse, India and SE Asia, see below) and now click OK. 

 

 
 

o. A new window pops up (for red difference) 

p. Put Field a Full Disk Himawari → 12.4 um → Temperature (wait) 

q. Put Field b Full Disk Himawari → 10.4 um → Temperature (wait) 

r. Click OK 

s. A new window pops up (for green difference) 

t. Put Field a Full Disk Himawari → 10.4 um → Temperature (wait) 

u. Put Field b Full Disk Himawari → 8.6 um → Temperature (wait) 

v. Click OK. 

w. The RGB image is displayed in the McIDAS-V window and the Layer Controls in the Data Explorer 

window. 

x. Set the ranges and the Gamma: -4 to +2 for red range, 0 to +15 for green, and 261 to 289 for blue. 

Gamma 0.4 for the green beam. Each input value has to be confirmed by Enter. The AHI RGB 

should look like this: 

 

 
 



Question: Have a look at water and ice clouds in this image. Compare to the Met-08 Dust RGB. Which 

one is better (better color contrast) for cloud phase detection? Measure the parallax shift between Met-08 

and Him-08 images (for high clouds). 

 

7. Create the Himawari-08 Dust RGBs for the same case (with the IR11.2 and IR12.4 channels) 

 

a. As above, use Imagery → Three Color (RGB) Image (Auto-scale) to generate the AHI Dust 

RGBs, with the same red and blue components, but with different green components. Use the same 

ranges and Gammas as above. Keep the same Region and the maximum resolution (should already 

be set). 

b. For the second AHI Dust RGB, use the difference IR11.2 – IR8.6 (on green). 

c. Finally, for the third AHI Dust RGB, use the difference IR12.4 – IR8.6 (on green). 

d. Compare all three AHI Dust RGBs to the SEVIRI Dust RGB: which one gives the best results (best 

contrast for cloud phase detection)? 

e. Do the results confirm the theory, namely that the AHI IR11.2 channel is the most suitable channel 

for being used on the green beam of the Dust RGB? 

f. Last but not least, try to fine tune the AHI Dust RGB (the one with the best contrast) by tuning all 

three color ranges. Can you find an optimal tuning? 

g.  

 

 

8. Extra task: look at this case in high resolution visible data 

 

a. Go to the Field Selector and display the high resolution visible band (AHI band 03, VIS0.64). 

Display the “albedo” in the range 0 to 100%. 

b. Compare the visible image to the Dust RGB: where is the visible image better, where the Dust 

RGB? 

c. Zoom on the thunderstorm over Northern India: compare to the Dust RGB - which features do you 

see? 

 

 

 

 

Annex: Dust RGB quick guide (from EUMeTrain) 



 



 


